Commonly asked questions


Do I need the latest version of flash ?

  Last Updated on March 9, 2015 at 9:18 am

Yes we suggest you have the latest version of Adobe Flash Player installed. If your computer or browser does not display the site as expected, then please click ‘here’ to find out more and download the latest version of Flash Player. Alternatively look at the question below which should help you further.

DISCLAIMER REGARDING UPGRADES & CHANGING YOUR COMPUTER’S SETTINGS:
Keeping your computer up-to-date is recommended, although it must be done at your own risk. WebCast-TV is not responsible or liable for any damage, failure, interruption or error to your computer and/or software or operating system with respect to any changes made based on the above suggested upgrades or settings.